Programação e Desenvolvimento

Projetos, softwares, sites, blogs e trabalhos conforme sua necessidade e com os melhores preços.
Tecnologia do Blogger.

Text Widget

Search (Don't Edit)

Sample Text

Formulir Kontak

Nome

E-mail *

Mensagem *

Full-Width Version (true/false)

Flickr

Facebook

Translate

Video of the Day

Slider (Add Label Name Here!) (Documentation Required)

Teste Teste Teste

Know us

Teste Teste Teste Teste

Popular Posts

Featured

29 de jun de 2014

Algoritmo em Visualg - Converter número decimal em Hexadecimal


Algoritmo em Visualg para conversão de números decimal em Hexadecimal.

 1 - O número a ser convertido não poderá ultrapassar de 5 dígitos.
 2 - Algoritmo não pode aceitar números negativos.
 3 - Cada etapa da conversão deve ser exibida, ou seja, cada resto da divisão e cada quociente devem ser          mostrados para cada etapa.
4 - Caso o numero convertido não seja suficientemente grande para preencher todo o vetor preencha os             espaços vazios com o numero Zero.
5 - Exibe o seguinte menu:

  1. Converter Número
  2. Sair.
Dúvidas deixe nos comentários.

algoritmo "Conversão em Hexadecimal"
// Função :  Converter número decimal em Hexadecimal
// Autor :   Marcos vinicius
// Data : 
// Seção de Declarações
var
   tabela: vetor[0..15] de caracter
   h: vetor[0..5] de caracter
   aux: vetor[0..5] de caracter
   op,num, cont,i:inteiro
   hexad: caracter
   resto: inteiro

inicio
        tabela[0]<- "0"
        tabela[1]<- "1"
        tabela[2]<- "2"
        tabela[3]<- "3"
        tabela[4]<- "4"
        tabela[5]<- "5"
        tabela[6]<- "6"
        tabela[7]<- "7"
        tabela[8]<- "8"
        tabela[9]<- "9"
        tabela[10]<- "A"
        tabela[11]<- "B"
        tabela[12]<- "C"
        tabela[13]<- "D"
        tabela[14]<- "E"
        tabela[15]<- "F"

      repita
         escreval("1 converter numero:")
         escreval("0 sair")
         escreval("sua opção:")
         leia (op)

         escolha op
         caso 1
            hexad<-""
            cont<-0
            escreval("dite um numero:")
            leia(num)
            escreval("-------------------------------")
            se (num <= 99999) e (num >=0)entao
               enquanto num>0 faca
                  escreval("Quociente: ",num)
                  resto<- (num mod 16)
                  num<- (num \ 16)
                  hexad<- tabela[resto]+hexad
                  h[cont]<- tabela[resto]+h[cont]
                  cont<-cont + 1
                  escreval("Resto da divisao: ",resto)
               fimenquanto
               escreval("---------------------------")
               cont<-0
                 para i de 0 ate 5 passo 1 faca
                    se(h[5-i]<>"")entao
                      aux[cont]<-h[5-i]
                      cont<-cont + 1
                    fimse
                fimpara
                escreva("Vetor: ")
                para i de 0 ate 5 passo 1 faca
                se(aux[i]="")entao
                  aux[i]<-"0"
                fimse
                 escreva(aux[i])
                 h[i]<- ""
                 aux[i]<- ""
                fimpara
                escreval()
               escreval("Hexadecimal: ", hexad)
            senao
                 escreval("numero invalido!")
            fimse

         caso 0
            escreval("sair")
         outrocaso
            escreval("opção invalida:")
         fimescolha
      ate op = 0

fimalgoritmo


Precisando de ajuda, entre em contato: https://mvf5-system.blogspot.com.br/2016/11/mvf5-system-solucoes-em-ti.html

←  Anterior Proxima  → Inicio

Postagem em destaque

MVF5 System - SOLUÇÕES EM TI!

          Desenvolvimento de projetos, softwares, sites, blogs e trabalhos conforme sua necessidade e com os melhores preços. Entre em c...

Seguidores

Total de visualizações

Postagens populares