Programação e Desenvolvimento

Projetos, softwares, sites, blogs e trabalhos conforme sua necessidade e com os melhores preços.
Tecnologia do Blogger.

Text Widget

Search (Don't Edit)

Sample Text

Formulir Kontak

Nome

E-mail *

Mensagem *

Full-Width Version (true/false)

Flickr

Facebook

Translate

Video of the Day

Slider (Add Label Name Here!) (Documentation Required)

Teste Teste Teste

Know us

Teste Teste Teste Teste

Popular Posts

Featured

13 de jan de 2015

Algoritmo em Visualg - Ordenar em ordem Alfabética


Algoritmo feito em Visualg que recebe vários dados de uma pessoa, preenchendo uma matriz de 5 posições, posterior preenchimento os dados serão ordenados pelo nome em ordem alfabética.

algoritmo "ordenar_Pelo_Nome"
// Função :  vai preencher um vetor depois vai ordenar
// Autor :   marcos vinicius
// Seção de Declarações
var
   nome:vetor[1..5,1..5]de caracter
   x,i:inteiro
   aux:caracter
inicio
// Seção de Comandos
   para x de 1 ate 5 passo 1 faca
        escreva("informe o nome: ")
        leia(nome[x,1])
        escreva("informe o endereco: ")
        leia(nome[x,2])
        escreva("informe o cep: ")
        leia(nome[x,3])
        escreva("informe o bairro: ")
        leia(nome[x,4])
        escreva("informe o telefone: ")
        leia(nome[x,5])
   fimpara
   para i de 1 ate 5 passo 1 faca
        para x de 1 ate 4 passo 1 faca
             se(nome[x,1] > nome[x+1,1])ENTAO
                aux<-nome[x,1]
                nome[x,1]<-nome[x+1,1]
                nome[x+1,1]<-aux
             fimse
        fimpara
   fimpara

   para i de 1 ate 5 passo 1 faca
        para x de 1 ate 5 passo 1 faca
          escreval(nome[i,x])
        fimpara
   fimpara
fimalgoritmo

Precisando de ajuda, entre em contato:
https://mvf5-system.blogspot.com.br/2016/11/mvf5-system-solucoes-em-ti.html
←  Anterior Proxima  → Inicio

Postagem em destaque

MVF5 System - SOLUÇÕES EM TI!

          Desenvolvimento de projetos, softwares, sites, blogs e trabalhos conforme sua necessidade e com os melhores preços. Entre em c...

Seguidores

Total de visualizações

Postagens populares